Technical Specifications for Current Releases

Version: 10.5.0.304
Date Released: 2017-11-16

CommonSpot 10.5.0

RAM

  • Authoring and Read Only Production Servers:
    • 4 GB minimum, 4 to 8 or more GB recommended for Linux
    • 4 GB minimum, 8 or more GB recommended for Windows
  • Lucee may run with less RAM than Adobe ColdFusion

Disk Space Available

  • 2 GB minimum for a 500 page site, 4-6 GB recommended as a start

Processors (Authoring/Read Only)

  • Processor: Single 64-bit 2 GHz Dual core processor minimum
  • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended

*Note: The authoring server will benefit from more processing power

Operating Systems

  • 64 bit OS required for all platforms
  • Microsoft Windows (latest service pack is required).
    • Adobe ColdFusion 11
      • Windows Server 2016
      • Windows Server 2012 R2
      • Windows Server 2008 R2
    • Adobe ColdFusion 2016, 11 and Lucee 5.2.2
      • Windows Server 2016
      • Windows Server 2012 R2
      • Windows Server 2008 R2
  • Linux:
    • Adobe ColdFusion 2016, 11 and Lucee 5.2.2
      • Red Hat Enterprise Linux 6/7
      • CentOS 6/7
      • Ubuntu 14.04 Server LTS
      • Amazon Linux

ColdFusion Requirements

  • 64 bit versions required.
  • Adobe ColdFusion 2016 (with update 5+) or 11 (with update 13+)
    • Do NOT enable Secure Profile
    • Only supported with Tomcat Application Server shipped with Adobe ColdFusion
  • Lucee 5.2.2.71 - NO LATER
(If you run multiple root level sites, please call PaperThin
Support for important, relevant information.)
  • Java:
    • Java 8 (update 144 or later) for Adobe ColdFusion and Lucee

Supported Databases for Adobe ColdFusion 2016

  • SQL Server:
    • 2016 Standard or Enterprise
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle:
    • 12c
    • 11gR2
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • Use the CommonSpot provided 'thin' JDBC driver
  • MySQL:

Supported Databases for Adobe ColdFusion 11

  • SQL Server:
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • 2008 R2 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle:
    • 12c
    • 11gR2
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • Use the CommonSpot provided 'thin' JDBC driver
  • MySQL:
    • 5.6.35 with the InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

Adobe ColdFusion 10 is not supported with Commonspot 10.5.0

Supported Databases for Lucee 5.2.2

  • SQL Server:
    • 2016 Standard or Enterprise
    • 2014 Standard or Enterprise
    • Use the out-of-box Microsoft SQL Server jdbc driver (version 6.2.1-jre8) extension
  • Oracle:
    • 12c
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • Use the out-of-box Oracle 12c jdbc driver (version 12.x) extension
  • MySQL:
    • 5.7, 5.6.35 with the InnoDB storage engine
    • Use the out-of-box MySQL jdbc driver (version 5.1.x) extension

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Microsoft Internet Explorer 11 and Edge (Windows)
  • Firefox ESR versions 52 and later (Windows, Linux, macOS/OS X)
  • Chrome versions 60 and later (Windows, Linux, macOS/OS X)
  • Safari 10 (macOS/OS X)
    • Limited Copy, Cut, Paste

Rich Text Editor

  • CKEditor Version 4.7.2 or Later.
  • Go to http://cdn.ckeditor.com to determine the latest version and how to format your URL to the CDN in Server Administration > Rich Text Editor Settings > Directories

Search Engine

  • Native Adobe ColdFusion 2016, 11 and Lucee 5.2
  • Full Apache Solr 5.4.0 or later. 6.5.0 preferred.

CommonSpot Application Development Framework

  • ADF Version 2.2. (ADF 2.1 does fully support the Widget Gallery functionality. ADF 2.2 will be released shortly.)

Minimum Screen Resolution

  • 1280 x 800
Version: 10.0.2.78
Date Released: 2016-11-02

Build 10.0.2.78 - Released Nov 2, 2016
Build 10.0.1.184 - Released July 29, 2016 - Retired Nov 2, 2016
Build 10.0.0.357 - Released Feb 29, 2016 - Retired July 29, 2016

CommonSpot 10.0.2

RAM

  • Authoring and Read Only Production Servers:
    • 4 GB minimum, 4 to 8 GB recommended for Linux
    • 4 GB minimum, 8 GB recommended for Windows
  • Lucee may run with less RAM than Adobe ColdFusion

Disk Space Available

  • 2 GB minimum for a 500 page site, 4-6 GB recommended as a start

Processors (Authoring/Read Only)

  • Processor: Single 64-bit 2 GHz Dual core processor minimum
  • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended

*Note: The authoring server will benefit from more processing power

Operating Systems

  • 64 bit OS required for all platforms
  • Microsoft Windows (latest service pack is required).
    • Adobe ColdFusion 2016, 11, 10 and Lucee 4.5.3
      • Windows Server 2016
      • Windows Server 2012 R2
      • Windows Server 2008 R2
  • Linux:
    • Adobe ColdFusion 2016, 11, 10 and Lucee 4.5.3
      • Red Hat Enterprise Linux 6
      • CentOS 6.7
      • Ubuntu 14.04 Server LTS

ColdFusion Requirements

  • 64 bit versions required.
  • Adobe ColdFusion 2016 (with update 3+), 11 (with update 10+) or Adobe ColdFusion 10 (with update 21+)
    • Do NOT enable Secure Profile
    • Tomcat Application Server shipped with Adobe ColdFusion
  • Lucee 4.5.3 (only - not later)

Since Lucee does not have a readily available download page to 4.5.3, as a convenience please use this one:

http://cdn.lucee.org/downloader.cfm/id/168/file/lucee-4.5.3.020-pl0-windows-installer.exe

  • Java:
    • Java 8 (update 102 or later) for Adobe ColdFusion and Lucee

Supported Databases for Adobe ColdFusion 2016

  • SQL Server:
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle:
    • 12c
    • 11g
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • Use the CommonSpot provided 'thin' JDBC driver
  • MySQL:

Supported Databases for Adobe ColdFusion 11

  • SQL Server:
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • 2008 R2 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle:
    • 12c
    • 11g
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • Use the CommonSpot provided 'thin' JDBC driver
  • MySQL:
    • 5.6.23 with the InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

Supported Databases for Adobe ColdFusion 10

  • SQL Server:
    • 2012 Standard or Enterprise
    • 2008 R2 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle:
    • 11g
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • Use the CommonSpot provided 'thin' JDBC driver
    • Adobe does not support Oracle 12c with ColdFusion 10
  • MySQL:
    • 5.6.23 with the InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

Supported Databases for Lucee 4.5.3

  • Oracle:
    • 12c
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • Use the CommonSpot provided 'thin' JDBC driver. The old jar file (ojdbc14.jar) must be deleted.

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Microsoft Internet Explorer 11 and Edge (Windows)
  • Firefox ESR versions 45 and later (Windows, Linux, OS X)
  • Chrome versions 51 and later (Windows, Linux, OS X)
  • Safari 9 (OS X) or Safari 10 (OS X)
    • Limited Copy, Cut, Paste

Rich Text Editor

  • CKEditor Version 4.4.9 or Later.
  • Go to http://cdn.ckeditor.com to determine the latest version and how to format your URL to the CDN in Server Administration > Rich Text Editor Settings > Directories

Search Engine

  • Native Adobe ColdFusion 2016, 11, 10 and Lucee 4.5.3
  • Apache SOLR 6.0.1

CommonSpot Application Development Framework

  • ADF Version 2.0.1

Minimum Screen Resolution

  • 1024 x 768
Version: 9.0.5.83
Date Released: 2016-11-02

Build 9.0.5.83- Released - Nov 2, 2016
Build 9.0.4.207 - Released - Aug 8, 2016 - Retired Nov 2, 2016
Build 9.0.3.119 - Released Aug 14, 2015 - Retired Aug 8, 2016
Build 9.0.2.94 - Released May 13, 2015 - Retired Aug 14, 2015
Build 9.0.1.175 - Released Oct 11, 2014 - Retired May 13, 2015
Build 9.0.0.441- Released Apr 12, 2014 - Retired Oct 11, 2014

RAM

  • Authoring and Read Only Production Servers:
    • 4 GB minimum, 4 to 8 GB recommended for Linux
    • 4 GB minimum, 8 GB recommended for Windows
  • Railo may run with less RAM than Adobe ColdFusion
     

Disk Space Available

  • 2 GB minimum for a 500 page site, 4-6 GB recommended as a start
     

Processors (Authoring/Read Only)

  • Processor: Single 64-bit 2 GHz Dual core processor minimum
  • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended

*Note: The authoring server will benefit from more processing power
 

Operating Systems

  • 64 bit OS required for all platforms
  • Microsoft Windows (latest service pack is required)
    • Adobe ColdFusion 11, 10 and Railo 4.2.1
      • Windows Server 2012 R2
      • Windows Server 2008 R2
  • Linux
    • Adobe ColdFusion 11, 10 and Railo 4.2.1
      • Red Hat Enterprise Linux 6
      • CentOS 6.6
      • Ubuntu 14.04 Server LTS

ColdFusion Requirements 

  • 64 bit versions required. All 32 bit versions are unsupported.
  • Adobe ColdFusion 11 (with update 10+) with Java 8 only
  • Adobe ColdFusion 10 (with update 21+) with Java 8 only
  • Railo 4.2.1
  • Java 8 (u102 min) required for Adobe ColdFusion and Railo

Supported Databases for Adobe ColdFusion 11

  • SQL Server
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • 2008 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle
    • 12c
    • 11g
    • NLS_CHARACTERSET setting 'AL32UTF8' recommended
    • Use the CommonSpot include thin client driver
    • Adobe ColdFusion Enterprise edition is required
  • MySQL
    • 5.6
    • InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

Supported Databases for Adobe ColdFusion 10

  • SQL Server
    • 2012 Standard or Enterprise
    • 2008 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle
    • 11g
    • NLS_CHARACTERSET setting 'AL32UTF8' recommended
    • Use the out-of-the-box 'datadirect' JDBC driver
    • Adobe ColdFusion Enterprise edition is required
  • MySQL
    • 5.6
    • InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

Supported Databases for Railo 4.2.1

  • SQL Server
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • 2008 Standard or Enterprise
    • JDBC driver: use jTDS driver
  • Oracle
    • 11g
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • JDBC driver: Railo did NOT ship the Oracle JDBC driver.
      • Download the driver from Oracle - http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html (the link could change later)
      • Download both ojdbc6.jar and orai18n.jar
  • MySQL

MySQL Notes

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Internet Explorer 10 and 11 (Windows)
  • Firefox ESR versions (Windows, Linux, Mac)
  • Chrome minimum version 42 (Windows, Linux, Mac)
  • Safari 6, 7 (Mac)
    • Limited Copy, Cut, Paste
       

CommonSpot Application Development Framework

  • ADF Version 1.8.1

Minimum Screen Resolution

  • 1024 x 768

Technical Specifications for Pre-Release-Public Releases

Version: 11.0.0.0
Date Released:

Specifications subject to change. Beta is not yet available.

CommonSpot 11.0.0 Future -

RAM

  • Authoring and Read Only Production Servers:
    • 4 GB minimum, 4 to 8 GB recommended for Linux
    • 4 GB minimum, 8 GB recommended for Windows
  • Lucee may run with less RAM than Adobe ColdFusion

Disk Space Available

  • 2 GB minimum for a 500 page site, 4-6 GB recommended as a start

Processors (Authoring/Read Only)

  • Processor: Single 64-bit 2 GHz Dual core processor minimum
  • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended

*Note: The authoring server will benefit from more processing power

Operating Systems

  • 64 bit OS required for all platforms
  • Microsoft Windows (latest service pack is required).
    • Adobe ColdFusion 2016, 11 Lucee 5
      • Windows Server 2016
      • Windows Server 2012 R2
      • Windows Server 2008 R2
  • Linux:
    • Adobe ColdFusion 2016, 11 and Lucee 5
      • Red Hat Enterprise Linux 6
      • CentOS 6.7
      • Ubuntu 14.04 Server LTS

ColdFusion Requirements

  • 64 bit versions required.
     
  • Adobe ColdFusion 2016 (with update 5), 11 (with update 13+)
    • Do NOT enable Secure Profile
    • Tomcat Application Server shipped with Adobe ColdFusion
  • Lucee 5.2.2.71
     
  • Java 8 (build 144)

Supported Databases for Adobe ColdFusion 2016

  • SQL Server:
    • 2014 Standard or Enterprise
    • 2012 R2 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle:
    • 12c
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • Use the CommonSpot provided 'thin' JDBC driver
       
  • MySQL:
    • 5.7.11 with the InnoDB storage engine
    • ColdFusion 2016 does not ship with the MySQL driver. Download and install it per instructions on the MySQL website.

Supported Databases for Adobe ColdFusion 11

  • SQL Server:
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle:
    • 12c
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • Use the CommonSpot provided 'thin' JDBC driver
  • MySQL:
    • 5.7.11 with the InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

 

Supported Databases for Lucee 5.2.2

  • SQL Server:
  • Oracle:
    • 12c
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • CommonSpot provided 'thin' JDBC driver. The old jar file must be deleted if upgrading (ojdbc14.jar)

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Microsoft Internet Explorer 11 and Edge (Windows)
  • Firefox ESR versions 52 and later (Windows, Linux, OS X)
  • Chrome versions 56 and later (Windows, Linux, OS X)
  • Safari 10 (macOS) or Safari 10 (OS X)
    • Limited Copy, Cut, Paste
  •  

Rich Text Editor

  • CKEditor Version 4.7.2 or Later.
  • Go to http://cdn.ckeditor.com to determine the latest version and how to format your URL to the CDN in Server Administration > Rich Text Editor Settings > Directories

Search Engine

  • Full Apache Solr 5.4.0 or later. 6.5.0 preferred.
  • Native search from Adobe ColdFusion and Lucee not recommended.

CommonSpot Application Development Framework

  • ADF Version 2.2

Minimum Screen Resolution

  • 1280 x 800
Version: 10.0.3.
Date Released:

10.0.3

Build 10.0.3.xxx - Released 2017
Build 10.0.2.78 - Released Nov 2, 2016
Build 10.0.1.184 - Released July 29, 2016 - Retired Nov 2, 2016
Build 10.0.0.357 - Released Feb 29, 2016 - Retired July 29, 2016

CommonSpot 10.0.3 - FUTURE

RAM

  • Authoring and Read Only Production Servers:
    • 4 GB minimum, 4 to 8 GB recommended for Linux
    • 4 GB minimum, 8 GB recommended for Windows
  • Lucee may run with less RAM than Adobe ColdFusion

Disk Space Available

  • 2 GB minimum for a 500 page site, 4-6 GB recommended as a start

Processors (Authoring/Read Only)

  • Processor: Single 64-bit 2 GHz Dual core processor minimum
  • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended

*Note: The authoring server will benefit from more processing power

Operating Systems

  • 64 bit OS required for all platforms
  • Microsoft Windows (latest service pack is required).
    • Adobe ColdFusion 2016, 11, 10 and Lucee 4.5.3
      • Windows Server 2016
      • Windows Server 2012 R2
      • Windows Server 2008 R2
  • Linux:
    • Adobe ColdFusion 2016, 11, 10 and Lucee 4.5.5
      • Red Hat Enterprise Linux 6
      • CentOS 6.7
      • Ubuntu 14.04 Server LTS

ColdFusion Requirements

  • 64 bit versions required.
  • Adobe ColdFusion 2016 (with update 5+) or 11 (with update 13+)
    • Do NOT enable Secure Profile
    • Tomcat Application Server shipped with Adobe ColdFusion
  • Lucee 4.5.5 (only - not later)
  • Java:
    • Java 8 (update 102 or later) for Adobe ColdFusion and Lucee

Supported Databases for Adobe ColdFusion 2016

  • SQL Server:
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle:
    • 12c
    • 11g
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • Use the CommonSpot provided 'thin' JDBC driver
  • MySQL:

Supported Databases for Adobe ColdFusion 11

  • SQL Server:
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • 2008 R2 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle:
    • 12c
    • 11g
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • Use the CommonSpot provided 'thin' JDBC driver
  • MySQL:
    • 5.6.23 with the InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

 

Supported Databases for Lucee 4.5.3

  • Oracle:
    • 12c
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • Use the CommonSpot provided 'thin' JDBC driver. The old jar file (ojdbc14.jar) must be deleted.

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Microsoft Internet Explorer 11 and Edge (Windows)
  • Firefox ESR versions 45 and later (Windows, Linux, OS X)
  • Chrome versions 51 and later (Windows, Linux, OS X)
  • Safari 9 (OS X) or Safari 10 (OS X)
    • Limited Copy, Cut, Paste

Rich Text Editor

  • CKEditor Version 4.7.2 or Later.
  • Go to http://cdn.ckeditor.com to determine the latest version and how to format your URL to the CDN in Server Administration > Rich Text Editor Settings > Directories

Search Engine

  • Native Adobe ColdFusion 2016, 11 and Lucee 4.5.3
  • Full Apache Solr 5.4.0 or later. 6.5.0 preferred.

CommonSpot Application Development Framework

  • ADF Version 2.0.1

Minimum Screen Resolution

  • 1024 x 768
Version: 9.0.6.1
Date Released:

Specifications subject to change. Beta is not available.

Build 9.0.6.xx - Released June xx, 2017 FUTURE
Build 9.0.5.83 - Released Nov 2, 2016 - Retired June xx, 2017
Build 9.0.4.207 - Released Aug 8, 2016 - Retired Nov 2, 2016
Build 9.0.3.119 - Released Aug 14, 2015 - Retired Aug 8, 2016
Build 9.0.2.94 - Released May 13, 2015 - Retired Aug 14, 2015
Build 9.0.1.175 - Released Oct 11, 2014 - Retired May 13, 2015
Build 9.0.0.441 - Released Apr 12, 2014 - Retired Oct 11, 2014

RAM

  • Authoring and Read Only Production Servers:
    • 4 GB minimum, 4 to 8 GB recommended for Linux
    • 4 GB minimum, 8 GB recommended for Windows
  • Railo may run with less RAM than Adobe ColdFusion
     

Disk Space Available

  • 2 GB minimum for a 500 page site, 4-6 GB recommended as a start
     

Processors (Authoring/Read Only)

  • Processor: Single 64-bit 2 GHz Dual core processor minimum
  • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended

*Note: The authoring server will benefit from more processing power
 

Operating Systems

  • 64 bit OS required for all platforms
  • Microsoft Windows (latest service pack is required)
    • Adobe ColdFusion 11 and Lucee 4.5.5
      • Windows Server 2012 R2
      • Windows Server 2008 R2
  • Linux
    • Adobe ColdFusion 11 and Lucee 4.5.5
      • Red Hat Enterprise Linux 6
      • CentOS 6.6
      • Ubuntu 14.04 Server LTS

ColdFusion Requirements 

  • 64 bit versions required. All 32 bit versions are unsupported.
  • Adobe ColdFusion 11 (with update 10+) with Java 8 only
  • Lucee 4.5.5.71
  • Java 8 (u121 min) required for Adobe ColdFusion and Lucee

Supported Databases for Adobe ColdFusion 11

  • SQL Server
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • 2008 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle
    • 12c
    • 11g
    • NLS_CHARACTERSET setting 'AL32UTF8' recommended
    • Use the CommonSpot include thin client driver
    • Adobe ColdFusion Enterprise edition is required
  • MySQL
    • 5.6
    • InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

Supported Databases for Lucee 4.5.5

  • SQL Server
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • 2008 Standard or Enterprise
    • Get latest driver from within Lucee
  • Oracle
    • 11g
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • JDBC driver: Railo did NOT ship the Oracle JDBC driver.
      • Download the driver from Oracle - http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html (the link could change later)
      • Download both ojdbc6.jar and orai18n.jar
  • MySQL

MySQL Notes

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Internet Explorer 10 and 11 (Windows)
  • Firefox ESR versions (Windows, Linux, Mac)
  • Chrome minimum version 42 (Windows, Linux, Mac)
  • Safari 6, 7 (Mac)
    • Limited Copy, Cut, Paste
       

CommonSpot Application Development Framework

  • ADF Version 1.8.1

Minimum Screen Resolution

  • 1280 x 800

Technical Specifications for Previous Releases

Version: 10.0.1.184
Date Released: 2016-07-29   Retired on: 2016-11-02

Build 10.0.1.184 - Released July 29, 2016 - Retired Nov 02, 2016
Build 10.0.0.357 - Released Feb 29, 2016 - Retired July 29, 2016

CommonSpot 10.0.1

RAM

  • Authoring and Read Only Production Servers:
    • 4 GB minimum, 4 to 8 GB recommended for Linux
    • 4 GB minimum, 8 GB recommended for Windows
  • Lucee may run with less RAM than Adobe ColdFusion

Disk Space Available

  • 2 GB minimum for a 500 page site, 4-6 GB recommended as a start

Processors (Authoring/Read Only)

  • Processor: Single 64-bit 2 GHz Dual core processor minimum
  • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended

*Note: The authoring server will benefit from more processing power

Operating Systems

  • 64 bit OS required for all platforms
  • Microsoft Windows (latest service pack is required).
    • Adobe ColdFusion 2016, 11, 10 and Lucee 4.5.2
      • Windows Server 2012 R2
      • Windows Server 2008 R2
  • Linux:
    • Adobe ColdFusion 2016, 11, 10 and Lucee 4.5.2
      • Red Hat Enterprise Linux 6
      • CentOS 6.7
      • Ubuntu 14.04 Server LTS

ColdFusion Requirements

  • 64 bit versions required.
     
  • Adobe ColdFusion 2016 (with update 3+), 11 (with update 10+) or Adobe ColdFusion 10 (with update 21+)
    • Do NOT enable Secure Profile
    • Tomcat Application Server shipped with Adobe ColdFusion
  • Lucee 4.5.3 (only - do not upgrade Lucee)
     
  • Java:
    • The latest Java 8 release for Adobe ColdFusion and Lucee
    • As of September 30, 2016 we require at least Java 1.8.0_102

Supported Databases for Adobe ColdFusion 2016

  • SQL Server:
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle:
    • 11g and 12c
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • Use the CommonSpot provided 'thin' JDBC driver
    • Adobe does not support Oracle 12c with ColdFusion 10
  • MySQL:
    • 5.6.23 with the InnoDB storage engine
    • ColdFusion 2016 does not ship with the MySQL driver. Download and install it per instructions on the MySQL website.

Supported Databases for Adobe ColdFusion 11

  • SQL Server:
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • 2008 R2 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle:
    • 12c
    • 11g
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • Use the CommonSpot provided 'thin' JDBC driver
  • MySQL:
    • 5.6.23 with the InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

Supported Databases for Adobe ColdFusion 10

  • SQL Server:
    • 2012 Standard or Enterprise
    • 2008 R2 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle:
    • 11g
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • Use the CommonSpot provided 'thin' JDBC driver
    • Adobe does not support Oracle 12c with ColdFusion 10
  • MySQL:
    • 5.6.23 with the InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

Supported Databases for Lucee 4.5.3

  • SQL Server:
  • Oracle:
    • 12c
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • CommonSpot provided 'thin' JDBC driver. The old jar file must be deleted if upgrading (ojdbc14.jar)

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Microsoft Internet Explorer 11 and Edge (Windows)
  • Firefox ESR versions 45 and later (Windows, Linux, OS X)
  • Chrome versions 51 and later (Windows, Linux, OS X)
  • Safari 9 (OS X) or Safari 10 (OS X)
    • Limited Copy, Cut, Paste

Rich Text Editor

  • CKEditor Version 4.4.9 or Later.
  • Go to http://cdn.ckeditor.com to determine the latest version and how to format your URL to the CDN in Server Administration > Rich Text Editor Settings > Directories

Search Engine

  • Native Adobe ColdFusion 2016, 11, 10 and Lucee 4.5.2
  • Apache SOLR 6.0.1

CommonSpot Application Development Framework

  • ADF Version 2.0.1

Minimum Screen Resolution

  • 1024 x 768
Version: 10.0.0.357
Date Released: 2016-02-29   Retired on: 2016-07-29

RAM

  • Authoring and Read Only Production Servers:
    • 4 GB minimum, 4 to 8 GB recommended for Linux
    • 4 GB minimum, 8 GB recommended for Windows
  • Railo may run with less RAM than Adobe ColdFusion

Disk Space Available

  • 2 GB minimum for a 500 page site, 4-6 GB recommended as a start

Processors (Authoring/Read Only)

  • Processor: Single 64-bit 2 GHz Dual core processor minimum
  • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended

*Note: The authoring server will benefit from more processing power

Operating Systems

  • 64 bit OS required for all platforms
  • Microsoft Windows (latest service pack is required).
    • Adobe ColdFusion 11, 10 and Lucee 4.5.2
      • Windows Server 2012 R2
      • Windows Server 2008 R2
  • Linux:
    • Adobe ColdFusion 11, 10 and Lucee 4.5.2
      • Red Hat Enterprise Linux 6
      • CentOS 6.7
      • Ubuntu 14.04 Server LTS

ColdFusion Requirements

  • 64 bit versions required. All 32 bit versions are unsupported.
     
  • Adobe ColdFusion 11 (with update 7+) or Adobe ColdFusion 10 (with update 18+)
    • Do NOT enable Secure Profile
    • Tomcat Application Server shipped with Adobe ColdFusion
       
  • Adobe ColdFusion 2016 is not supported.
  • Lucee 4.5.2 (Railo is no longer supported)
     
  • Java:
    • The latest Java 8 release for Adobe ColdFusion and Lucee
    • Java 7 is no longer supported by Oracle as of April 2015
       

Supported Databases for Adobe ColdFusion 11

  • SQL Server:
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • 2008 R2 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle:
    • 12c
    • 11g
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • Use the CommonSpot provided 'thin' JDBC driver
  • MySQL:
    • 5.6.23 with the InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

Supported Databases for Adobe ColdFusion 10

  • SQL Server:
    • 2012 Standard or Enterprise
    • 2008 R2 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle:
    • 11g
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • Use the CommonSpot provided 'thin' JDBC driver
    • Adobe does not support Oracle 12c with ColdFusion 10
  • MySQL:
    • 5.6.23 with the InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

Supported Databases for Lucee 4.5.2

  • SQL Server:
  • Oracle:
    • 12c
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • CommonSpot provided 'thin' JDBC driver. The old jar file must be deleted if upgrading (ojdbc14.jar)

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Microsoft Internet Explorer 11 and Edge (Windows)
  • Firefox ESR versions 38 and later (Windows, Linux, OS X)
  • Chrome versions 48 and later (Windows, Linux, OS X)
  • Safari 9 (OS X)
    • Limited Copy, Cut, Paste

Rich Text Editor

  • CKEditor Version 4.4.7 or Later.
  • Go to http://cdn.ckeditor.com to determine the latest version and how to format your URL to the CDN in Server Administration > Rich Text Editor Settings > Directories

Search Engine

  • Native Adobe ColdFusion 11, 10 and Lucee 4.5.2
  • Apache SOLR 5.4

CommonSpot Application Development Framework

  • ADF Version 2.0.1

Minimum Screen Resolution

  • 1024 x 768
Version: 9.0.4.207
Date Released: 2016-08-08   Retired on: 2016-11-02

Build 9.0.4.207 - Release Aug 8, 2016 - Retired Nov 02, 2016
Build 9.0.3.119 - Released Aug 14, 2015 - Retired Aug 8, 2016
Build 9.0.2.94 - Released May 13, 2015 - Retired Aug 14, 2015
Build 9.0.1.175 - Released Oct 11, 2014 - Retired May 13, 2015
Build 9.0.0.441- Released Apr 12, 2014 - Retired Oct 11, 2014

RAM

  • Authoring and Read Only Production Servers:
    • 4 GB minimum, 4 to 8 GB recommended for Linux
    • 4 GB minimum, 8 GB recommended for Windows
  • Railo may run with less RAM than Adobe ColdFusion
     

Disk Space Available

  • 2 GB minimum for a 500 page site, 4-6 GB recommended as a start
     

Processors (Authoring/Read Only)

  • Processor: Single 64-bit 2 GHz Dual core processor minimum
  • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended

*Note: The authoring server will benefit from more processing power
 

Operating Systems

  • 64 bit OS required for all platforms
  • Microsoft Windows (latest service pack is required)
    • Adobe ColdFusion 11, 10 and Railo 4.2.1
      • Windows Server 2012 R2
      • Windows Server 2008 R2
  • Linux
    • Adobe ColdFusion 11, 10 and Railo 4.2.1
      • Red Hat Enterprise Linux 6
      • CentOS 6.6
      • Ubuntu 14.04 Server LTS

ColdFusion Requirements 

Must read regarding Adobe ColdFusion

  • 64 bit versions required. All 32 bit versions are unsupported.
  • Adobe ColdFusion 11 (with update 5+) with Java 1.8 only
  • Adobe ColdFusion 10 (with update 16+) with Java 1.7 or 1.8
  • Adobe ColdFusion 9.0.2 is no longer supported with CommonSpot 9.0.4

  • Railo 4.2.1

  • Java
    • Java 8 (u31 min) recommended for Adobe ColdFusion and Railo
    • Java 7 (u71 min) is no longer supported by Oracle as of April 2015

Supported Databases for Adobe ColdFusion 11

  • SQL Server
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • 2008 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle
    • 12c
    • 11g
    • NLS_CHARACTERSET setting 'AL32UTF8' recommended
    • Use the CommonSpot include thin client driver
    • Adobe ColdFusion Enterprise edition is required
  • MySQL
    • 5.6
    • InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

Supported Databases for Adobe ColdFusion 10

  • SQL Server
    • 2012 Standard or Enterprise
    • 2008 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle
    • 11g
    • NLS_CHARACTERSET setting 'AL32UTF8' recommended
    • Use the out-of-the-box 'datadirect' JDBC driver
    • Adobe ColdFusion Enterprise edition is required
  • MySQL
    • 5.6
    • InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

Supported Databases for Railo 4.2.1

  • SQL Server
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • 2008 Standard or Enterprise
    • JDBC driver: use jTDS driver
  • Oracle
    • 11g
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • JDBC driver: Railo did NOT ship the Oracle JDBC driver.
      • Download the driver from Oracle - http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html (the link could change later)
      • Download both ojdbc6.jar and orai18n.jar
  • MySQL

MySQL Notes

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Internet Explorer 10 and 11 (Windows)
  • Firefox ESR versions (Windows, Linux, Mac)
  • Chrome minimum version 42 (Windows, Linux, Mac)
  • Safari 6, 7 (Mac)
    • Limited Copy, Cut, Paste
       

CommonSpot Application Development Framework

  • ADF Version 1.8.1

Minimum Screen Resolution

  • 1024 x 768
Version: 9.0.3.119
Date Released: 2015-08-14   Retired on: 2016-08-08

RAM

  • Authoring and Read Only Production Servers:
    • 4 GB minimum, 4 to 8 GB recommended for Linux
    • 4 GB minimum, 8 GB recommended for Windows
  • Railo may run with less RAM than Adobe ColdFusion
     

Disk Space Available

  • 2 GB minimum for a 500 page site, 4-6 GB recommended as a start
     

Processors (Authoring/Read Only)

  • Processor: Single 64-bit 2 GHz Dual core processor minimum
  • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended

*Note: The authoring server will benefit from more processing power
 

Operating Systems

  • 64 bit OS required for all platforms
  • Microsoft Windows (latest service pack is required)
    • Adobe ColdFusion 11, 10 and Railo 4.2.1
      • Windows Server 2012 R2
      • Windows Server 2008 R2
  • Linux
    • Adobe ColdFusion 11, 10 and Railo 4.2.1
      • Red Hat Enterprise Linux 6
      • CentOS 6.6
      • Ubuntu 14.04 Server LTS

ColdFusion Requirements 

Must read regarding Adobe ColdFusion

  • 64 bit versions required. All 32 bit versions are unsupported.
     
  • Adobe ColdFusion 11 (with update 5+) with Java 1.8 only
  • Adobe ColdFusion 10 (with update 16+) with Java 1.7 or 1.8
  • Adobe ColdFusion 9.0.2 (with update 1) and Java 1.7 or 1.8

    • Not officially supported due to potential security risks because there are no more updates for Java 1.7, but a viable environment for CommonSpot.

  • Railo 4.2.1

  • Java
    • Java 8 (u31 min) recommended for Adobe ColdFusion and Railo
    • Java 7 (u71 min) is no longer supported by Oracle as of April 2015

Supported Databases for Adobe ColdFusion 11

  • SQL Server
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • 2008 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle
    • 12c
    • 11g
    • NLS_CHARACTERSET setting 'AL32UTF8' recommended
    • Use the CommonSpot include thin client driver
    • Adobe ColdFusion Enterprise edition is required
  • MySQL
    • 5.6
    • InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

Supported Databases for Adobe ColdFusion 10

  • SQL Server
    • 2012 Standard or Enterprise
    • 2008 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle
    • 11g
    • NLS_CHARACTERSET setting 'AL32UTF8' recommended
    • Use the out-of-the-box 'datadirect' JDBC driver
    • Adobe ColdFusion Enterprise edition is required
  • MySQL
    • 5.6
    • InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

Supported Databases for Railo 4.2.1

  • SQL Server
    • 2014 Standard or Enterprise
    • 2012 Standard or Enterprise
    • 2008 Standard or Enterprise
    • JDBC driver: use jTDS driver
  • Oracle
    • 11g
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • JDBC driver: Railo did NOT ship the Oracle JDBC driver.
      • Download the driver from Oracle - http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html (the link could change later)
      • Download both ojdbc6.jar and orai18n.jar
  • MySQL

MySQL Notes

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Internet Explorer 10 and 11 (Windows)
  • Firefox ESR versions (Windows, Linux, Mac)
  • Chrome minimum version 42 (Windows, Linux, Mac)
  • Safari 6, 7 (Mac)
    • Limited Copy, Cut, Paste
       

CommonSpot Application Development Framework

  • ADF Version 1.8.1

Minimum Screen Resolution

  • 1024 x 768
Version: 9.0.2.94
Date Released: 2015-05-13   Retired on: 2015-08-14

RAM

  • Authoring and Read Only Production Servers:
    • 4 GB minimum, 4 to 8 GB recommended for Linux
    • 4 GB minimum, 8 GB recommended for Windows
  • Railo may run with less RAM than Adobe ColdFusion
     

Disk Space Available

  • 2 GB minimum for a 500 page site, 4-6 GB recommended as a start
     

Processors (Authoring/Read Only)

  • Processor: Single 64-bit 2 GHz Dual core processor minimum
  • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended

*Note: The authoring server will benefit from more processing power
 

Operating Systems

  • 64 bit OS required for all platforms
  • Microsoft Windows (latest service pack is required)
    • Adobe ColdFusion 11, 10 and Railo 4.2.1
      • Windows Server 2012 R2
      • Windows Server 2008 R2
  • Linux
    • Adobe ColdFusion 11, 10 and Railo 4.2.1
      • Red Hat Enterprise Linux 6
      • CentOS 6.6
      • Ubuntu 14.04 Server LTS

ColdFusion Requirements 

Must read regarding Adobe ColdFusion

  • 64 bit versions required. All 32 bit versions are unsupported.
     
  • Adobe ColdFusion 11 (with update 5+) or Adobe ColdFusion 10 (with update 16+)
  • ColdFusion 9.x not support by Adobe on Java 1.8. For security reasons Java 1.8 is required, therefor we do not officially support ColdFusion 9, though CommonSpot 8.x and 9.x will run on ColdFusion 9.0.2 and Java 1.7.

  • Railo 4.2.1

  • Java
    • Java 8 recommended for Adobe ColdFusion and Railo
    • Java 7 is no longer supported by Oracle as of April 2015

Supported Databases for Adobe ColdFusion 10, 11

  • SQL Server
    • 2012 Standard or Enterprise
    • 2008 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle
    • 11g
    • NLS_CHARACTERSET setting 'AL32UTF8' recommended
    • Use the out-of-the-box 'datadirect' JDBC driver
    • Adobe ColdFusion Enterprise edition is required
  • MySQL
    • 5.6
    • InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

Supported Databases for Railo 4.2.1

  • SQL Server
    • 2012 Standard or Enterprise
    • 2008 Standard or Enterprise
    • JDBC driver: use jTDS driver
  • Oracle
    • 11g
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • JDBC driver: Railo did NOT ship the Oracle JDBC driver.
      • Download the driver from Oracle - http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html (the link could change later)
      • Download both ojdbc6.jar and orai18n.jar
  • MySQL

MySQL Notes

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Internet Explorer 10 and 11 (Windows)
  • Firefox ESR versions (Windows, Linux, Mac)
  • Chrome minimum version 42 (Windows, Linux, Mac)
  • Safari 6, 7 (Mac)
    • Limited Copy, Cut, Paste - see Documentation
       

CommonSpot Application Development Framework

  • ADF Version 1.8.1

Minimum Screen Resolution

  • 1024 x 768
Version: 9.0.1.175
Date Released: 2014-10-10   Retired on: 2015-05-13

If using the ADF, ColdFusion 11 Requires ADF 1.8.1 (1.8.0 with patch)
See details on the Community Site

RAM

  • Authoring and Read Only Production Servers:
    • 4 GB minimum, 4 to 8 GB recommended for Linux and Solaris
    • 4 GB minimum, 8 GB recommended for Windows
  • Railo may run with less RAM than Adobe ColdFusion

Disk Space Available

2 GB minimum for a 500 page site, 4-6 GB recommended as a start

Processors (Authoring/Read Only)

  • Windows and Linux
    • Processor: Single 64-bit 2 GHz Dual core processor minimum
    • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended
  • Solaris
    • SPARC processor

*Note: The authoring server will benefit from more processing power

Operating Systems

  • 64 bit OS required for all platforms
  • Microsoft Windows (latest service pack is required).
    • Adobe CF 11 and 10
      • Windows Server 2012 R2
      • Windows Server 2008 R2
    • Adobe CF 9.0.2
      • Windows Server 2003 R2
    • Railo 4.1.2
      • Windows Server 2012 R2
      • Windows Server 2008 R2
  • Linux:
    • Adobe CF 11, 10 & 9.0.2 and Railo 4.1.2
      • Red Hat Enterprise Linux 6
      • CentOS 6.4
      • Ubuntu 12.04 Server LTS
  • Solaris 10: running on SPARC processor only
    • Adobe CF 11, 10 & 9.0.2

ColdFusion Requirements 

Must read regarding Adobe ColdFusion

  • 64 bit versions required. All 32 bit versions are unsupported.
     
  • Adobe ColdFusion 11 (with update 1) or ColdFusion 10 (with update 12 or 13)
    • Do NOT enable Secure Profile
    • Solr Search Engine Only
    • Tomcat Application Server shipped with Adobe ColdFusion
      • Adobe no longer supports JRUN
    • Only the out-of-the-box 'datadirect' JDBC drive for all databases
    • See Article about new location of class path information
       
  • Adobe ColdFusion 9.0.2 (with HF 1 minimum)
    • Solr Search Engine Only (see KB Article re: memory)
    • Adobe JRun 4 Application Server (Updater 7) only
    • Only the out-of-the-box 'datadirect' JDBC driver is supported for all databases

Supported Databases for Adobe ColdFusion 10 or 11

  • SQL Server:
    • Supported Versions:
      • 2012 R2 Standard or Enterprise
      • 2008 R2 Standard or Enterprise
         
  • Oracle:
    • Supported Versions:
      • Oracle 11g R2 (NLS_CHARACTERSET setting 'AL32UTF8' recommended)
      • 10g (10.2.0.1 and above) R2
         
    • Not Supported: Oracle 12c -Not yet supported by Adobe-
    • Adobe requires ColdFusion Enterprise edition for Oracle Databases|
       
  • MySQL:
    • Supported Versions
      • 5.6 with the InnoDB storage engine
      • 5.5 with the InnoDB storage engine

Supported Databases for Adobe ColdFusion 9.0.2

  • SQL Server:
    • Supported Versions:
      • 2008
      • 2008 R2
         
  • Oracle:
    • Supported Versions:
      • 11g R2 (NLS_CHARACTERSET setting 'AL32UTF8' recommended)
      • 10g (10.2.0.1 and above) R2
      • Adobe requires ColdFusion Enterprise edition for Oracle Databases
    • Not Supported: Oracle 12c - Not yet supported by Adobe
       
  • MySQL:
    • Supported Versions:
      • 5.6 with the InnoDB storage engine
      • 5.5 or later not supported

Supported Database for Railo 4.1.2.005

  • MySQL version 5.5 or 5.6
    • configure use of the InnoDB storage engine
  • Oracle 11gR2 (NLS_CHARACTERSET setting must be 'AL32UTF8')
    • JDBC driver: Railo did NOT ship the Oracle JDBS driver.
      • Download the driver from Oracle- http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html (the link could change later)
      • Download both ojdbc6.jar and orai18n.jar
    • Not Supported: Oracle 12c
  • SQL Server 2012 R2, 2008 R2 Standard or Enterprise, with jTDS driver
     

MySQL Notes

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

CommonSpot Application Development Framework

  • ADF Version 1.8.0
  • ADF Version 1.8.1 required for ColdFusion 11

Minimum Screen Resolution

  • 1024 x 768
Version: 9.0.0.441
Date Released: 2014-04-12   Retired on: 2014-04-11

RAM

  • Authoring and Read Only Production Servers:
    • 4 GB minimum, 4 to 32 GB recommended for Linux and Solaris
    • 4 GB minimum, 8 to 32 GB recommended for Windows
       
  • Recommend assigning 2 GB less than the server allocation to ColdFusion for all operating systems
  • Railo may run with less RAM than Adobe ColdFusion
     

Disk Space Available

  • 2 GB minimum for a 500 page site, 4-6 GB recommended as a start
     

Processors (Authoring/Read Only)

  • Windows and Linux
    • Processor: Single 64-bit 2 GHz Dual core processor minimum
    • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended
       
  • Solaris
    • SPARC processor

*Note: The authoring server will benefit from more processing power

Operating Systems

  • 64 bit OS required for all platforms
  • Microsoft Windows (latest service pack is required).
    • Adobe CF 11 and 10
      • Windows Server 2012 R2
      • Windows Server 2008 R2
    • Adobe CF 9.0.2
      • Windows Server 2003 R2
    • Railo 4.1.2
      • Windows Server 2012 R2
      • Windows Server 2008 R2
  • Linux:
    • Adobe CF 11, 10 & 9.0.2 and Railo 4.1.2
      • Red Hat Enterprise Linux 6
      • CentOS 6.4
      • Ubuntu 12.04 Server LTS
         
  • Solaris 10: running on SPARC processor only
    • Adobe CF 11, 10 & 9.0.2
       

ColdFusion Requirements 

Must Read regarding Adobe ColdFusion

  • 64 bit versions required. All 32 bit versions are unsupported.
     
  • Adobe ColdFusion 11 (with update 1) or ColdFusion 10 (with update 12 or 13)
    • Do NOT enable Secure Profile
    • Solr Search Engine Only
    • Tomcat Application Server shipped with Adobe ColdFusion
      • Adobe no longer supports JRUN
    • Only the out-of-the-box 'datadirect' JDBC drive for all databases
    • See Article about new location of class path information
       
  • Adobe ColdFusion 9.0.2 (with HF 1 minimum)
    • Solr Search Engine Only (see KB Article re: memory)
    • Adobe JRun 4 Application Server (Updater 7) only
    • Only the out-of-the-box 'datadirect' JDBC driver is supported for all databases

Supported Databases for Adobe ColdFusion 10 or 11

  • SQL Server:
    • Supported Versions:
      • 2012 R2 Standard or Enterprise
      • 2008 R2 Standard or Enterprise
  • Oracle:
    • Supported Versions:
      • Oracle 11g R2 (NLS_CHARACTERSET setting 'AL32UTF8' recommended)
      • 10g (10.2.0.1 and above) R2
         
    • Not Supported: Oracle 12c -Not yet supported by Adobe-
    • Adobe requires ColdFusion Enterprise edition for Oracle Databases
  • MySQL:
    • Supported Versions
      • 5.6 with the InnoDB storage engine
      • 5.5 with the InnoDB storage engine

Supported Databases for Adobe ColdFusion 9.0.2

  • SQL Server:
    • Supported Versions:
      • 2008
      • 2008 R2
  • Oracle:
    • Supported Versions:
      • 11g R2 (NLS_CHARACTERSET setting 'AL32UTF8' recommended)
    • 10g (10.2.0.1 and above) R2
    • Not Supported: Oracle 12c - Not yet supported by Adobe
    • Adobe requires ColdFusion Enterprise edition for Oracle Databases
  • MySQL:
    • Supported Versions:
      • 5.6 with the InnoDB storage engine
      • 5.5 or later not supported
         

Supported Database for Railo 4.1.2.005

  • MySQL version 5.5 or 5.6
    • configure use of the InnoDB storage engine
  • Oracle 11gR2 (NLS_CHARACTERSET setting must be 'AL32UTF8')
    • JDBC driver: Railo did NOT ship the Oracle JDBS driver.
      • Download the driver from Oracle- http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html (the link could change later)
      • Download both ojdbc6.jar and orai18n.jar
    • Not Supported: Oracle 12c
  • SQL Server 2012 R2, 2008 R2 Standard or Enterprise, with jTDS driver
     

MySQL Notes

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Internet Explorer 9 and 10 and 11 (Windows)
  • Firefox ESR versions 24 and 31 (Windows, Linux, Mac)
  • Chrome minimum version 37 (Windows, Linux, Mac)
  • Safari 6, 7 (Mac)
    • Limited Copy, Cut, Paste - see Documentation
       

CommonSpot Application Development Framework

  • ADF Version 1.8
     

Minimum Screen Resolution

  • 1024 x 768
Version: 8.0.5.434
Date Released: 2016-11-02

Build 8.0.5.434 - Released Nov 02, 2016
Build 8.0.4.221 - Released May 13, 2015 - Desupported Oct xx, 2016
Build 8.0.3.164 - Released Apr 11, 2014 - Desupported May 13, 2015
Build 8.0.2.221 - Released Apr 04, 2013 - Desupported April 11, 2014
Build 8.0.1.213 - Released Mar 15, 2013 - Desupported April 16, 2013
Build 8.0.0.106 - Released Sep 21, 2012 - Desupported March 15, 2013

RAM

  • Authoring and Read Only Production Servers:
    • 4 GB minimum, 4 to 8 GB recommended for Linux
    • 4 GB minimum, 8 GB recommended for Windows
  • Railo may run with less RAM than Adobe ColdFusion

Disk Space Available

  • 2 GB minimum for a 500 page site, 4-6 GB recommended

Processors (Authoring/Read Only)

  • Processor: 64-bit 2 GHz Dual core processor minimum
  • Processor: 64-bit 2 GHz (or higher) Quad core processor recommended

*Note: The authoring server will benefit from more processing power

Operating Systems - 64 bit required

  • Microsoft Windows
    • Windows Server 2012 R2
    • Windows Server 2008 R2
    • The latest service pack is required.
  • Linux:
    • Red Hat Enterprise Linux 6
    • CentOS 6.4
    • Ubuntu 12.04 Server LTS

ColdFusion Requirements - 64 bit required

  • Adobe ColdFusion 9.x (any version) is no longer supported
  • Railo 4.2.1
  • Java 8 only
    • Java 8 (update 102 or later) required for Adobe ColdFusion and Railo

Database - Adobe ColdFusion 10

  • SQL Server:
    • 2012 Standard or Enterprise
    • 2008 R2 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle:
    • 11g R2
    • 10g R2
    • NLS_CHARACTERSET setting 'AL32UTF8' recommended
    • Use the out-of-the-box 'datadirect' JDBC driver
    • Adobe ColdFusion Enterprise edition is required
  • MySQL:
    • 5.6
    • 5.5
    • InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

Database - Railo 4.2.1

  • SQL Server:
    • 2012 Standard or Enterprise
    • 2008 R2 Standard or Enterprise
    • JDBC driver: jTDS driver
  • Oracle:
    • 11gR2
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • JDBC driver: Railo did NOT ship the Oracle jdbc driver.
      • Download the driver from Oracle- http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html (the link could change later)
      • Download both ojdbc6.jar and orai18n.jar
  • MySQL:
    • 5.6
    • 5.5
    • InnoDB storage engine

Database - MySQL

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Internet Explorer 10 and 11 (Windows)
  • Firefox ESR versions (Windows, Linux, Mac) as they are released will be patched if necessary as quickly as possible. Firefox 17 and later ESR has security enhancements that limit Cut, Copy and Paste options - see Documentation.
  • Chrome minimum version 42 (Windows, Linux, Mac) (Limited Copy, Cut, Paste - see Documentation) (Chrome RTE Limitation)
  • Safari 6, 7 (Mac) (Limited Copy, Cut, Paste - see Documentation)

CommonSpot Application Development Framework

  • ADF Version 1.8.1

Minimum Screen Resolution

  • 1024 x 768
Version: 8.0.4.305
Date Released: 2015-05-13   Retired on: 2016-11-02

Build 8.0.4.305 - Released May 13, 2015 - Retired Nov 02, 2016
Build 8.0.3.164 - Released Apr 11, 2014 - Retired May 13, 2015
Build 8.0.2.221 - Released Apr 04, 2013 - Retired April 11, 2014
Build 8.0.1.213 - Released Mar 15, 2013 - Retired April 16, 2013
Build 8.0.0.106 - Released Sep 21, 2012 - Retired March 15, 2013

RAM

  • Authoring and Read Only Production Servers:
    • 4 GB minimum, 4 to 8 GB recommended for Linux
    • 4 GB minimum, 8 GB recommended for Windows
  • Railo may run with less RAM than Adobe ColdFusion

Disk Space Available

  • 2 GB minimum for a 500 page site, 4-6 GB recommended

Processors (Authoring/Read Only)

  • Processor: 64-bit 2 GHz Dual core processor minimum
  • Processor: 64-bit 2 GHz (or higher) Quad core processor recommended

*Note: The authoring server will benefit from more processing power

Operating Systems - 64 bit required

  • Microsoft Windows
    • Windows Server 2008 R2
    • Windows Server 2003 R2
    • The latest service pack is required.
  • Linux:
    • Red Hat Enterprise Linux 6
    • CentOS 6.4
    • Ubuntu 12.04 Server LTS

ColdFusion Requirements - 64 bit required

Special Note: If considering Adobe ColdFusion 10 this is must read.

  • Adobe ColdFusion 9.0.2 (with update 1) and Java 1.7 or 1.8
  • For security reasons Java 1.7 should no longer be used, but ColdFusion 9.0.2 or 10.0 with Java 1.7 will run.
     
  • Railo 4.2.1
  • Java
    • Java 8 for Adobe ColdFusion and Railo
    • Java 7 is no longer supported by Oracle as of April 2015

Database - Adobe ColdFusion 10

  • SQL Server:
    • 2012 Standard or Enterprise
    • 2008 R2 Standard or Enterprise
    • Use the out-of-the-box 'datadirect' JDBC driver
  • Oracle:
    • 11g R2
    • 10g R2
    • NLS_CHARACTERSET setting 'AL32UTF8' recommended
    • Use the out-of-the-box 'datadirect' JDBC driver
    • Adobe ColdFusion Enterprise edition is required
  • MySQL:
    • 5.6
    • 5.5
    • InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.

Database - Railo 4.2.1

  • SQL Server:
    • 2012 Standard or Enterprise
    • 2008 R2 Standard or Enterprise
    • JDBC driver: jTDS driver
  • Oracle:
    • 11gR2
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • JDBC driver: Railo did NOT ship the Oracle jdbc driver.
      • Download the driver from Oracle- http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html (the link could change later)
      • Download both ojdbc6.jar and orai18n.jar
  • MySQL:
    • 5.6
    • 5.5
    • InnoDB storage engine

Database - MySQL

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Internet Explorer 10 and 11 (Windows)
  • Firefox ESR versions (Windows, Linux, Mac) as they are released will be patched if necessary as quickly as possible. Firefox 17 and later ESR has security enhancements that limit Cut, Copy and Paste options - see Documentation.
  • Chrome minimum version 42 (Windows, Linux, Mac) (Limited Copy, Cut, Paste - see Documentation) (Chrome RTE Limitation)
  • Safari 6, 7 (Mac) (Limited Copy, Cut, Paste - see Documentation)

CommonSpot Application Development Framework

  • ADF Version 1.8.1

Minimum Screen Resolution

  • 1024 x 768
Version: 8.0.3.164
Date Released: 2014-04-11   Retired on: 2015-05-13

Build 8.0.2.221 - Released Apr 04, 2013 - Desupported April 11, 2014
Build 8.0.1.213 - Released Mar 15, 2013 - Desupported April 16, 2013
Build 8.0.0.106 - Released Sep 21, 2012 - Desupported March 15, 2013

RAM

  • Authoring and Read Only Production Servers:
    • 4 GB minimum, 4 to 8 GB recommended for Linux and Solaris
    • 4 GB minimum, 8 GB recommended for Windows
  • Recommend assigning 2 GB less than the server allocation to ColdFusion for all operating systems
  • Railo requires less RAM than Adobe ColdFusion for equal performance

Disk Space Available

  • 2 GB minimum for a 500 page site, 4-6 GB recommended

Processors (Authoring/Read Only)

  • Windows and Linux
    • Processor: 64-bit 2 GHz Dual core processor minimum
    • Processor: 64-bit 2 GHz (or higher) Quad core processor recommended
  • Solaris
    • SPARC processor
    • only the 64 bit Adobe ColdFusion version is supported

*Note: The authoring server will benefit from more processing power

Operating Systems - 64 bit required

  • Microsoft Windows
    • Windows Server 2008 R2
    • Windows Server 2003 R2
    • The latest service pack is required.
  • Linux:
    • Red Hat Enterprise Linux 6
    • CentOS 6.4
    • Ubuntu 12.04 Server LTS
  • Solaris 10: running on SPARC processor only

ColdFusion Requirements - 64 bit required

Special Note: If considering Adobe ColdFusion 10 this is must read.

  • Adobe ColdFusion 9.0.2 with HF 1
    • Solr Search Engine Only (see KB Article re: memory)
    • Adobe JRun 4 Application Server (Updater 7) only
    • Only the out-of-the-box 'datadirect' JDBC driver is supported for all databases
  • Adobe ColdFusion 10 with latest update (minimum 12)
    • Do NOT enable Secure Profile
    • Solr Search Engine Only
    • Tomcat Application Server shipped with Adobe ColdFusion 10 
    • Adobe no longer supports JRUN in Coldfusion 10
    • Only the out-of-the-box 'datadirect' JDBC driver is supported for all databases
    • See Article about new location of class path information in CF 10.
  • Railo 4.1.2.005
  • Oracle JDK 1.7.0_(latest update) for all ColdFusion engines.
  • JDK 1.6.x is no longer supported by Adobe or Oracle

Database - Adobe ColdFusion 10

  • SQL Server 2012, 2008 R2 Standard or Enterprise
  • MySQL version 5.5, 5.6 with InnoDB storage engine
  • Oracle 12c is not yet supported by Adobe
  • Includes DB versions supported by ColdFusion 9.0.2 below

Database - Adobe ColdFusion 9.0.2 with HF 1

  • SQL Server 2008, 2008 R2
  • Oracle 10g (10.2.0.1 and above) R2
  • Oracle 11g R2 (NLS_CHARACTERSET setting 'AL32UTF8' recommended)
    • Adobe requires ColdFusion Enterprise edition for Oracle Databases
  • MySQL version 5.5 with the InnoDB storage engine (5.6 or later not supported)
  • See PaperThin KB articles for Oracle and MySQL details

Database - Railo 4.1.2.005

  • Oracle 11gR2 (NLS_CHARACTERSET setting must be 'AL32UTF8')
    • JDBC driver: Railo did NOT ship the Oracle jdbc driver. Download the driver from Oracle- http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html (the link could change later)
    • Downlaod both ojdbc6.jar and orai18n.jar
       
  • SQL Server 2012, 2008 R2 Standard or Enterprise, with jTDS driver

Database - MySQL

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Internet Explorer 9, 10 and 11 (Windows)
  • Firefox ESR versions (Windows, Linux, Mac) as they are released will be patched if necessary as quickly as possible. Firefox 17 and later ESR has security enhancements that limit Cut, Copy and Paste options - see Documentation.
  • Chrome minimum version 31 (Windows, Linux, Mac) (Limited Copy, Cut, Paste - see Documentation) (Chrome RTE Limitation)
  • Safari 6, 7 (Mac) (Limited Copy, Cut, Paste - see Documentation)

CommonSpot Application Development Framework

  • ADF Version 1.6.2

Minimum Screen Resolution

  • 1024 x 768
Version: 8.0.2.221
Date Released: 2013-04-16   Retired on: 2014-04-11

Build 8.0.1.213 - Released Mar 15, 2013 - Desupported April 16, 2013
Build 8.0.0.106 - Released Sep 21, 2012 - Desupported March 15, 2013

RAM

  • Authoring and Read Only Production Servers:
    • 4 GB minimum, 4 to 8 GB recommended for Linux and Solaris
    • 4 GB minimum, 8 GB recommended for Windows with minimum 4 GB allocated to ColdFusion
  • Recommend assigning 2 GB less than the server allocation to ColdFusion for all operating systems
  • Railo requires less RAM than Adobe ColdFusion

Disk Space Available

  • 2 GB minimum for a 500 page site, 4-6 GB recommended

Processors (Authoring/Read Only)

  • Windows and Linux
    • Processor: 64-bit 2 GHz Dual core processor minimum
    • Processor: 64-bit 2 GHz (or higher) Quad core processor recommended
  • Solaris
    • SPARC processor

*Note: The authoring server will benefit from more processing power

Operating Systems - 64 bit required

  • Microsoft Windows
    • Windows Server 2008 R2
    • Windows Server 2003 R2
    • The latest service pack is required.
  • Linux:
    • Red Hat Enterprise Linux 5
    • CentOS 5.8/6.2
    • Ubuntu 10.04.4 Server LTS
    • 64 bit OS recommended
  • Solaris 10: running on SPARC processor only

ColdFusion Requirements - 64 bit required

Special Note: If considering Adobe ColdFusion 10 this is must read.

  • Adobe ColdFusion 9.0.2
    • Solr Search Engine Only
    • Adobe JRun 4 Application Server (Updater 7) only
    • Only the out-of-the-box 'datadirect' JDBC driver is supported for all databases
  • Adobe ColdFusion 10 with update 9 or later
    • When installing CF disable Secure Profile (on by default)
    • Solr Search Engine Only
    • ColdFusion 10.0.9 (update 9)
    • Tomcat Application Server shipped with Adobe ColdFusion 10 
    • Adobe no longer supports JRUN in Coldfusion 10
    • Only the out-of-the-box 'datadirect' JDBC driver is supported for all databases
    • See Article about new location of class path information in CF 10.
  • Railo 3.3.4.003 - Standalone and Shared Database Only, Replication not Supported **
  • Oracle JDK 1.6.0_33 or later for all ColdFusion engines.
  • Oracle JDK 1.7.0_15 or later for all ColdFusion engines.

Database - Adobe ColdFusion 9.02 and 10

  • SQL Server 2005, 2008, 2008 R2
  • SQL Server 2008 Enterprise Edition R2 with jTDS driver
  • Oracle 10g (10.2.0.1 and above) R2
  • Oracle 11g R1
  • Oracle 11g R2 (NLS_CHARACTERSET setting must be 'AL32UTF8' required)
  • Adobe requires ColdFusion Enterprise edition for Oracle Databases
  • MySQL version 5.1 with the InnoDB storage engine
  • MySQL version 5.5 with the InnoDB storage engine
  • See PaperThin KB articles for Oracle and MySQL details

Database - Railo 3.3.4.003

  • Oracle 11gR2 (NLS_CHARACTERSET setting must be 'AL32UTF8')
    • Jdbc driver: Railo did NOT ship the Oracle jdbc driver. Download the driver from Oracle- http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html (the link could change later)
    • Downlaod both ojdbc6.jar and orai18n.jar
  • SQL Server 2008 Enterprise Edition R2 with jTDS driver

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Internet Explorer 8 and 9 and 10 (Windows)
  • Firefox ESR versions (Windows, Linux, Mac) as they are released will be patched if necessary as quickly as possible. Firefox 17 and later ESR has security enhancements that limit Cut, Copy and Paste options - see Documentation.
  • Chrome 24 and 25 (Windows, Linux, Mac) (Limited Copy, Cut, Paste - see Documentation)
  • Safari 5 (Mac) (Limited Copy, Cut, Paste - see Documentation)

ADF Minimum Version 1.6.1

Minimum Screen Resolution: 1024 x 768

** Replication on Railo may be offered in future versions of CommonSpot

Version: 8.0.0.106
Date Released: 2012-09-21   Retired on: 2013-03-15

RAM

  • Authoring and Read Only Production Servers:
    • 2 GB minimum, 4 to 8 GB recommended for Linux and Solaris
    • 4 GB minimum, 8 GB recommended for Windows with minimum 2 GB allocated to ColdFusion
  • Recommend assigning 2 GB less than the server allocation to ColdFusion
  • Railo requires less RAM than Adobe ColdFusion

Disk Space Available

  • 2 GB minimum, 4-6 GB recommended

Processors (Authoring/Read Only)

  • Windows and Linux
    • Processor: Single 64-bit 2 GHz Dual core processor minimum
    • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended
  • Solaris
    • SPARC processor

*Note: The authoring server will benefit from more processing power

Operating Systems

  • Microsoft Windows (64 bit only)
    • Windows Server 2008 R2
    • Windows Server 2003 R2
    • The latest service pack is required.
  • Linux:
    • Red Hat Enterprise Linux 5
    • CentOS 5.8/6.2
    • Ubuntu 10.04.4 Server LTS
    • 64 bit OS recommended
  • Solaris 10: running on SPARC processor only

ColdFusion Requirements

  • Adobe ColdFusion 9.0.2
    • 64 bit ColdFusion only
    • Solr Search Engine Only
    • Adobe JRun 4 Application Server (Updater 7) only
    • Only the out-of-the-box 'datadirect' JDBC driver is supported for all databases
  • Adobe ColdFusion 10
    • 64 bit ColdFusion only
    • Solr Search Engine Only
    • ColdFusion 10.0.1 (update 1)
    • Tomcat Application Server shipped with Adobe ColdFusion 10
    • Only the out-of-the-box 'datadirect' JDBC driver is supported for all databases
    • See Article about new location of class path information in CF 10.
  • Railo 3.3.4.003
  • Oracle JDK 1.6.0_33 or later for all ColdFusion engines.
  • Oracle JDK 1.7.0_15 or later for all ColdFusion engines.

Database - Adobe ColdFusion 9.02 and 10

  • SQL Server 2005
  • SQL Server 2008 Enterprise Edition
  • SQL Server 2008 Enterprise Edition R2
  • Oracle 10g (10.2.0.1 and above) R2
  • Oracle 11g R1
  • Oracle 11g R2 (NLS_CHARACTERSET setting must be 'AL32UTF8' required)
  • Adobe requires ColdFusion Enterprise edition for Oracle Databases
  • MySQL version 5.1 with the InnoDB storage engine
  • MySQL version 5.5 with the InnoDB storage engine
  • See PaperThin KB articles for Oracle and MySQL details

Database - Railo 3.3.4.003

  • Oracle 11gR2 (NLS_CHARACTERSET setting must be 'AL32UTF8')
    • Jdbc driver: Railo did NOT ship the Oracle jdbc driver. Download the driver from Oracle- http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html (the link could change later)
    • Downlaod both ojdbc6.jar and orai18n.jar
  • SQL Server 2008 Enterprise Edition R2 with jTDS driver

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

CommonSpot Application Development Framework

  • ADF Version 1.6

Minimum Screen Resolution: 1024 x 768

Version: 7.0.3.
Date Released:

RAM

  • Authoring and Read Only Production Servers: 4 GB minimum, 4 to 8 GB recommended

Disk Space Available

  • 2 GB minimum, 4-6 GB recommended

Processors (Authoring/Read Only)

  • Windows and Linux
    • Processor: Single 32-bit (x86) 2 GHz Dual core processor minimum
    • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended
  • Solaris
    • SPARC processor

*Note: The authoring server will benefit from more processing power

Operating Systems

It is recommended to run CommonSpot 7.0.2 on a 64 bit OS with 4GB of ram allocated to JRUN if running Windows. Sites may not run well or may fail the upgrade on 32 bit systems.

  • Microsoft Windows
    • Windows Server 2008 R2
    • Windows Server 2003 R2
    • 64 bit Windows recommended
    • The latest service pack is required.
  • Linux:
    • Red Hat Enterprise Linux 6
    • CentOS 6.4
    • Ubuntu 12.04 Server LTS
    • 64 bit OS recommended
  • Solaris 10: running on SPARC processor only
    • only the 64 bit Adobe ColdFusion is supported

ColdFusion Requirements

  • Adobe ColdFusion 9.0.1 with HF 4
    • JDK 1.7
  • Adobe ColdFusion 9.0.2 with HF 1, only if you do not use Verity. Verity Not included with 9.0.2
    • JDK 1.7
    • Note: Adobe ColdFusion 8.0.0, 8.0.1, 9.0.0, and 10 are NOT supported.
  • Adobe JRun 4 Application Server (Updater 7) only
  • Search on Solr is NOT supported.
  • Railo 4.1.2.005

Java

  • Adobe supports the JDK 1.7 for ColdFusion 9 and 10 only
  • JDK 1.7 is no longer supported by Adobe and Oracle April 2015
  • JDK 1.6.x is no longer supported by Adobe or Oracle

Database - Adobe ColdFusion 8.x is not support with this Service Pack

Database - Adobe ColdFusion 9.0.1/9.0.2

  • Microsoft SQL Server
    • 2008, 2008 R2
    • Only the out-of-the-box DataDirect JDBC driver is supported
  • Oracle
    • 10g R2, 11g R2
    • Adobe requires ColdFusion Enterprise edition for Oracle Databases
    • Only the out-of-the-box DataDirect JDBC driver is supported
  • MySQL
    • Versions 5.5 (5.6 or later not supported)
    • with the InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.
  • See PaperThin KB articles for Oracle and MySQL details

Database - Railo 4.1.2.005

  • MySQL 5.5, 5.6
  • Oracle 11g R2
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • JDBC driver: Railo did NOT ship the Oracle JDBC driver. Download the driver from Oracle- http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html (the link could change later). Download both ojdbc6.jar and orai18n.jar
  • Microsoft SQL Server 2008 R2, 2012
    • JDBC driver: jTDS driver

Database - MySQL

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Internet Explorer 9, 10 and 11 on Windows
  • Firefox ESR versions (Windows, Linux, Mac) as they are released will be patched if necessary as quickly as possible. Firefox 17 and later ESR has security enhancements that limit Cut, Copy and Paste options - see Documentation.
  • Chrome minimum version 31 (Windows, Linux, Mac) (Limited Copy, Cut, Paste - see Documentation) (Chrome RTE Limitation)
  • Safari 6, 7 (Mac) (Limited Copy, Cut, Paste - see Documentation)

ADF Minimum Version 1.6.2

Minimum Screen Resolution: 1024 x 768

 

Version: 7.0.2.143
Date Released: 2014-04-11   Retired on: 2016-02-29

Servers running 7.0.2 should follow the hardware requirements for 8.0.3.

As of April 2015, Oracle stopped support for Java 7. As such PaperThin recommends upgrading to Java 8 and CommonSpot 9.0.2.

Additionally, PaperThin will no longer be releasing any hot-fixes for Commonspot 7.0.2 under Railo.

RAM

  • Authoring and Read Only Production Servers: 4 GB minimum, 4 to 8 GB recommended

Disk Space Available

  • 2 GB minimum, 4-6 GB recommended

Processors (Authoring/Read Only)

  • Windows and Linux
    • Processor: Single 32-bit (x86) 2 GHz Dual core processor minimum
    • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended
  • Solaris
    • SPARC processor

*Note: The authoring server will benefit from more processing power

Operating Systems

It is recommended to run CommonSpot 7.0.2 on a 64 bit OS with 4GB of ram allocated to JRUN if running Windows. Sites may not run well or may fail the upgrade on 32 bit systems.

  • Microsoft Windows
    • Windows Server 2008 R2
    • Windows Server 2003 R2
    • 64 bit Windows recommended
    • The latest service pack is required.
  • Linux:
    • Red Hat Enterprise Linux 6
    • CentOS 6.4
    • Ubuntu 12.04 Server LTS
    • 64 bit OS recommended
  • Solaris 10: running on SPARC processor only
    • only the 64 bit Adobe ColdFusion is supported

ColdFusion Requirements

  • Adobe ColdFusion 9.0.1 with HF 4
  • Adobe ColdFusion 9.0.2 with HF 1, only if you do not use Verity. Verity Not included with 9.0.2
    • Note: Adobe ColdFusion 8.0.0, 8.0.1, 9.0.0, and 10 are NOT supported.
  • Adobe JRun 4 Application Server (Updater 7) only
  • Search on Solr is NOT supported.
  • Railo 4.1.2.005
  • Adobe supported the JDK 1.7 for ColdFusion 9 and 10 only at time of initial release. JDK 1.7 is no longer supported by Oracle. You may run on JDK 1.7 with limited PaperThin support of CommonSpot 7.0.2, but prefer that you upgrade to a later 8.0.4 or 9.0.2 or later.

Database - Adobe ColdFusion 8.x is not support with this Service Pack

Database - Adobe ColdFusion 9.0.1/9.0.2

  • Microsoft SQL Server
    • 2008, 2008 R2
    • Only the out-of-the-box DataDirect JDBC driver is supported
       
  • Oracle
    • 10g R2, 11g R2
    • Adobe requires ColdFusion Enterprise edition for Oracle Databases
    • Only the out-of-the-box DataDirect JDBC driver is supported
       
  • MySQL
    • Versions 5.5 (5.6 or later not supported)
    • with the InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.
       
  • See PaperThin KB articles for Oracle and MySQL details

Database - Railo 4.1.2.005

  • MySQL 5.5, 5.6
  • Oracle 11g R2
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • JDBC driver: Railo did NOT ship the Oracle JDBC driver. Download the driver from Oracle- http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html (the link could change later). Download both ojdbc6.jar and orai18n.jar
       
  • Microsoft SQL Server 2008 R2, 2012
    • JDBC driver: jTDS driver

Database - MySQL

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Internet Explorer 9, 10 and 11 on Windows
  • Firefox ESR versions (Windows, Linux, Mac) as they are released will be patched if necessary as quickly as possible. Firefox 17 and later ESR has security enhancements that limit Cut, Copy and Paste options - see Documentation.
  • Chrome minimum version 31 (Windows, Linux, Mac) (Limited Copy, Cut, Paste - see Documentation) (Chrome RTE Limitation)
  • Safari 6, 7 (Mac) (Limited Copy, Cut, Paste - see Documentation)

CommonSpot Appication Development Framework

  • ADF v1.6.2

Minimum Screen Resolution

  • 1024 x 768

 

Version: 7.0.1.62
Date Released: 2013-04-05   Retired on: 2014-04-12

The 7.0.1 specs are the same as the 7.0.0 specs with the exception of additional browser support.

We currently recommend that servers running 7.0.1 follow the minimum hardware requirements for 8.0.2.

RAM

  • Authoring and Read Only Production Servers
    • 2 GB minimum, 4 to 8 GB recommended

Disk Space Available

  • 2 GB minimum, 4-6 GB recommended

Processors (Authoring/Read Only)

  • Windows and Linux
    • Processor: Single 32-bit (x86) 2 GHz Dual core processor minimum
    • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended
  • Solaris
    • SPARC processor

*Note: The authoring server will benefit from more processing power

Operating Systems

It is recommended to run Winter 2012 on a 64 bit OS with 4GB of ram allocated to JRUN if running Windows. Sites may not run well or may fail the upgrade on 32 bit systems.

  • Microsoft Windows
    • Windows Server 2008 R2:
      • only Adobe ColdFusion 9.0.1 and Railo 3.3.2 are supported.
    • Windows Server 2008,2003 R2,2003
    • 64 bit Windows recommended
    • The latest service pack is required.
  • Linux:
    • Red Hat Enterprise Linux 5
    • CentOS 5.8/6.2
    • Ubuntu 10.04.4 Server LTS
    • 64 bit OS recommended
  • Solaris 10: running on SPARC processor only
    • only the 64 bit Adobe ColdFusion is supported

ColdFusion Requirements

  • Adobe ColdFusion 9.0.1 with HF 1 (http://kb2.adobe.com/cps/862/cpsid_86263.html)
  • Adobe ColdFusion 9.0.2 only if you do not use Verity. Not included with 9.0.2
    • Requires CommonSpot patch 7.0.0.34
  • Adobe ColdFusion 8.0.1 with HF 4 (http://kb2.adobe.com/cps/529/cpsid_52915.html)
    • Note: Adobe ColdFusion 8.0.0, 9.0.0, and 10 are NOT supported.
    • Adobe JRun 4 Application Server (Updater 7) only
    • Search on Solr is NOT supported.
  • Railo 3.3.2 - Standalone and Shared Database Only. Replication not supported
    • Note: Railo 3.3.1 is NOT supported.
    • Tomcat Application Server (version 7 recommended) only
  • Both CF engines require Sun JDK 1.6.0_24 for ColdFusion 8.0.1 and 9.0.1 and 9.0.2
  • JDK 1.6.9_29 is not supported
  • Adobe supports the JDK 1.7 for ColdFusion 9 and 10 only

Database - Adobe ColdFusion 8.0.1

  • Microsoft SQL Server 2005
    • Only the out-of-the-box DataDirect JDBC driver is supported
  • Oracle 10g R2
    • Adobe requires ColdFusion Enterprise edition for Oracle Databases
    • Only the out-of-the-box DataDirect JDBC driver is supported
  • MySQL 5.1
    • with the InnoDB storage engine
    • Data Source driver type 'MySQL (3)' is NOT supported. Use 'MySQL (4/5)' instead.
  • See PaperThin KB articles for Oracle and MySQL details

Database - Adobe ColdFusion 9.0.1/9.0.2

  • Microsoft SQL Server
    • 2005, 2008, 2008 R2
    • Only the out-of-the-box DataDirect JDBC driver is supported
  • Oracle
    • 10g R2, 11g R1, 11g R2
    • Adobe requires ColdFusion Enterprise edition for Oracle Databases
    • Only the out-of-the-box DataDirect JDBC driver is supported
  • MySQL version
    • 5.1, 5.5
    • with the InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.
  • See PaperThin KB articles for Oracle and MySQL details

Database - Railo 3.3.2

  • MySQL 5.5
  • Oracle 11g R2
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • JDBC driver: Railo did NOT ship the Oracle JDBC driver. Download the driver from Oracle- http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html (the link could change later). Download both ojdbc6.jar and orai18n.jar
  • Microsoft SQL Server 2008 R2
    • JDBC driver: jTDS driver

Authoring Browser Requirements

CommonSpot 7.0.1 supports these browser versions for authoring content.

  • Internet Explorer 8 and 9, IE 10 on Windows 7 ONLY (Windows 8 is not supported)
  • Firefox 10 ESR and Firefox 17 ESR version (Windows, Linux, Mac) 17 ESR has security enhancements that limit Cut, Copy and Paste options - see Documentation.
  • Chrome 24 and 25 (Windows, Linux, Mac) (Limited Copy, Cut, Paste - see Documentation)
  • Safari 5 (Mac) (Limited Copy, Cut, Paste - see Documentation)

CommonSpot Application Development Framework

  • ADF Minimum Version 1.6.1 (Read the ADF 1.6 Upgrade Guide)

Minimum Screen Resolution

  • 1024 x 768
Version: 7.0.0.202
Date Released: 2012-04-01   Retired on: 2013-04-05

RAM

  • Authoring and Read Only Production Servers: 2 GB minimum, 4 to 8 GB recommended

Disk Space Available

  • 2 GB minimum, 4-6 GB recommended

Processors (Authoring/Read Only)

  • Windows and Linux
    • Processor: Single 32-bit (x86) 2 GHz Dual core processor minimum
    • Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended
  • Solaris
    • SPARC processor

*Note: The authoring server will benefit from more processing power

Operating Systems

It is recommended to run Winter 2012 on a 64 bit OS with 4GB of ram allocated to JRUN if running Windows. Sites may not run well or may fail the upgrade on 32 bit systems.

  • Microsoft Windows
    • Windows Server 2008 R2:
      • only Adobe ColdFusion 9.0.1 and Railo 3.3.2 are supported.
    • Windows Server 2008,2003 R2,2003
    • 64 bit Windows recommended
    • The latest service pack is required.
  • Linux:
    • Red Hat Enterprise Linux 5
    • CentOS 5.8/6.2
    • Ubuntu 10.04.4 Server LTS
    • 64 bit OS recommended
  • Solaris 10: running on SPARC processor only
    • only the 64 bit Adobe ColdFusion is supported

ColdFusion Requirements

  • Adobe ColdFusion 9.0.1 with HF 1 (http://kb2.adobe.com/cps/862/cpsid_86263.html)
  • Adobe ColdFusion 9.0.2 only if you do not use Verity. Not included with 9.0.2
    • Requires CommonSpot patch 7.0.0.34
  • Adobe ColdFusion 8.0.1 with HF 4 (http://kb2.adobe.com/cps/529/cpsid_52915.html)
    • Note: Adobe ColdFusion 8.0.0, 9.0.0, and 10 are NOT supported.
    • Adobe JRun 4 Application Server (Updater 7) only
    • Search on Solr is NOT supported.
  • Railo 3.3.2
    • Note: Railo 3.3.1 is NOT supported.
    • Tomcat Application Server (version 7 recommended) only
  • Both CF engines require Sun JDK 1.6.0_24 for ColdFusion 8.0.1 and 9.0.1 and 9.0.2
  • JDK 1.6.9_29 is not supported
  • Adobe supports the JDK 1.7 for ColdFusion 9 and 10 only

Database - Adobe ColdFusion 8.0.1

  • Microsoft SQL Server 2005
    • Only the out-of-the-box DataDirect JDBC driver is supported
  • Oracle 10g R2
    • Adobe requires ColdFusion Enterprise edition for Oracle Databases
    • Only the out-of-the-box DataDirect JDBC driver is supported
  • MySQL 5.1
    • with the InnoDB storage engine
    • Data Source driver type 'MySQL (3)' is NOT supported. Use 'MySQL (4/5)' instead.
  • See PaperThin KB articles for Oracle and MySQL details

Database - Adobe ColdFusion 9.0.1/9.0.2

  • Microsoft SQL Server
    • 2005, 2008, 2008 R2
    • Only the out-of-the-box DataDirect JDBC driver is supported
  • Oracle
    • 10g R2, 11g R1, 11g R2
    • Adobe requires ColdFusion Enterprise edition for Oracle Databases
    • Only the out-of-the-box DataDirect JDBC driver is supported
  • MySQL version
    • 5.1, 5.5
    • with the InnoDB storage engine
    • Data Source driver type 'MySQL (DataDirect)' is NOT supported. Use 'MySQL (4/5)' instead.
  • See PaperThin KB articles for Oracle and MySQL details

Database - Railo 3.3.2

  • MySQL 5.5
  • Oracle 11g R2
    • NLS_CHARACTERSET setting must be 'AL32UTF8'
    • JDBC driver: Railo did NOT ship the Oracle JDBC driver. Download the driver from Oracle- http://www.oracle.com/technetwork/database/enterprise-edition/jdbc-112010-090769.html (the link could change later). Download both ojdbc6.jar and orai18n.jar
  • Microsoft SQL Server 2008 R2
    • JDBC driver: jTDS driver

Authoring Browser Requirements

CommonSpot supports any of the following browser versions for authoring content.

  • Internet Explorer 8 and 9 (Windows)
  • Firefox 10 ESR version (Windows, Linux, Mac OS X)
  • Firefox 3.6 until desupported by Mozilla in April 2012
  • Chrome 14 (Windows, Linux, Mac OS X) (Limited Copy, Cut, Paste - see Documentation)
  • Safari 5 (Mac OS X) (Limited Copy, Cut, Paste - see Documentation)

ADF Minimum Version 1.5.2

Minimum Screen Resolution: 1024 x 768

Version: 6.2.1.16
Date Released: 2012-04-04   Retired on: 2014-04-11

RAM

  • Authoring and Read Only Production Servers: 2 GB minimum, 4 GB recommended

Disk Space Available

  • I GB minimum, 4-6 GB recommended

Processors (Authoring/Read Only)

  • Windows and Linux: Single 32-bit (x86) 2 GHz Dual core processor minimum, Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended
  • Solaris: Sun SPARC (Dual processors recommended)

*Note: The authoring server will benefit from more processing power

Operating Systems(Windows OS requires the latest service pack,** requires ColdFusion 9.0.1)

  • Windows Server 2008 R2 **
  • Windows Server 2008
  • Windows Server 2003 R2
  • Windows Server 2003
  • Linux: Red Hat Linux 5 or SUSE Linux Enterprise 10
  • Solaris 10: for SPARC (only the 64 bit CF/JVM version is supported)

ColdFusion Requirements

  • ColdFusion 9.0.1 with HF 1 (http://kb2.adobe.com/cps/862/cpsid_86263.html)
  • ColdFusion 8.0.1 with HF 4 (http://kb2.adobe.com/cps/529/cpsid_52915.html)
  • Note: ColdFusion 8.0.0 and 9.0.0 are NOT supported.
  • Adobe JRun 4 Application Server (Updater 7) only
  • Note: Application Servers other than JRun are NOT supported.
  • Sun JDK 1.6.0_24 for ColdFusion 8.0.1 and 9.0.1 and 9.0.2
  • Adobe supports the JDK 1.7 for ColdFusion 9.0.2 and 10 only

Databases (** requires ColdFusion 9.0.1)

  • SQL Server 2008 Enterprise Edition R2 **
  • SQL Server 2008 Enterprise Edition **
  • SQL Server 2005
  • Adobe requires ColdFusion Enterprise edition for Oracle Databases
  • Oracle 11g R2 **
  • Oracle 11g ** (NLS_CHARACTERSET setting must be 'AL32UTF8' required)
  • Oracle 10g (10.2.0.1 and above)
  • MySQL 5.1 (with InnoDB storage engine) **
  • MySQL 5.0.x (where x is greater than 25) with InnoDB storage engine
  • See PaperThin KB articles for Oracle and MySQL details

Authoring Browser Requirements

  CommonSpot supports any of the following browser versions for authoring content. Firefox runs
on Mac OS X, Linux, and Windows. Internet Explorer runs only on Windows.

  • Internet Explorer 8
  • Internet Explorer 9
  • Firefox 10 ESR Only

ADF Minimum Version 1.5.2

Minimum Screen Resolution: 1024 x 768

Version: 6.0.0.732
Date Released: 2010-05-11   Retired on: 2011-07-27

RAM

  • Authoring and Read Only Production Servers: 2 GB minimum, 4 GB recommended

Disk Space Available

  • I GB minimum, 4-6 GB recommended

Processors (Authoring/Read Only)

  • Windows and Linux: Single 32-bit (x86) 2 GHz Dual core processor minimum, Dual 64-bit (x64) 2 GHz (or higher) Dual core processor recommended
  • Solaris: Sun SPARC (Dual processors recommended)

*Note: The authoring server will benefit from more processing power

Operating Systems

  • Windows Server 2008 64 bit (with latest service pack)
  • Windows Server 2008 32 bit (with latest service pack)
  • Windows Server 2003 R2 64 bit (with latest service pack)
  • Windows Server 2003 R2 32 bit (with latest service pack)
  • Windows Server 2003 64 bit (with latest service pack)
  • Windows Server 2003 32 bit (with latest service pack)
  • Linux: Red Hat Linux 5 or SUSE Linux Enterprise 10
  • Solaris 10: for SPARC

ColdFusion Requirements
Since the release of 6.0, Adobe recommends JDK 1.6.0_24 for both CF 8 and 9.
At the time of release, lower versions were acceptable.

  • ColdFusion 9.0.0 with HF 1 (9.0.1 highly recommended)
  • ColdFusion 8.0.1 with HF 4
  • ColdFusion 7.0.2 with HF 3 (Windows only)
  • Note: Only ColdFusion 8.0.1 and 9.0.0 are supported for 64-bit environments
  • JRUN Application Server only for all configurations

Databases

  • SQL Server 2008 Enterprise Edition (10.0.1200.1) (ColdFusion 9 only)
  • SQL Server 2005
  • Adobe requires ColdFusion Enterprise for Oracle Databases
  • Oracle 11g, 11gR1 (ColdFusion 9 Enterprise only)
  • Oracle 10g (10.2.0.1 and above)
  • MySQL 5.1 (ColdFusion 9 and InnoDB storage engine)
  • MySQL 5.0.x (where x is greater than 25) with InnoDB storage engine
  • See PaperThin KB articles for Oracle and MySQL details

Authoring Browser Requirements

  CommonSpot supports any of the following browser versions for authoring content. Firefox runs
on Mac OS X, Linux, and Windows. Internet Explorer runs only on Windows.

  • Internet Explorer 8 (running IE8 compatibility mode)
  • Internet Explorer 7
  • Firefox 3.5 or 3.6

Minimum Screen Resolution: 1024 x 768